The ALL Florida Online Corvette Club






Corvette Top Sites

Go Back   The ALL Florida Online Corvette Club > General Corvette Forums > Maintenance, Mods, & Tips


Maintenance, Mods, & Tips Mods | Tips | Repairs & Troubleshooting

Reply
Thread Tools Display Modes
Unread 05-12-2017, 07:11 PM   #1
Rich Z
Internet Sanitation Engineer
 
Rich Z's Avatar
 
Join Date: Mar 2006
Location: Crawfordville, FL
Posts: 12,810
Name : Rich Zuchowski
Rich Z will become famous soon enoughRich Z will become famous soon enough
Default Service Antilock Brakes

A little while back, I was pulling the C6Z06 out of the garage for Connie and I to take a drive, and while sitting on the garage apron, I felt the brake pedal kind of shudder a bit, and heard what sounded like a faint *pop* from somewhere. Then the DIC started yelping, cycling through the following three error messages:
  1. SERVICE ANTILOCK BRAKES
  2. SERVICE ACTIVE HANDLING SYSTEM
  3. SERVICE TRACTION SYSTEM

Well, obviously we weren't going anywhere with that car, so I pulled it back into the garage. Connie had some plans with her sister for a week, so not much I could do till she got back.

In the meantime, I put the car up on the lift and gave a visual inspection, but nothing jumped out at me. The wheel speed sensor cables looked fine from what I could see. I disconnected the battery and reconnected it, but the error messages persisted.

Since I had purchased GM's extended warranty (and it was expiring this upcoming September), I contacted the local Chevy dealership in Tallahassee (Dale Earnhardt Jr Chevrolet), and made arrangements to bring the car in for service.

Which I did this past Monday.

What had failed was the driver's side front wheel speed sensor. Which meant replacing the hub, since the sensor is integrated into the hub itself. They also found that the brake master cylinder was leaking into the booster as well. So they replaced the hub on that corner, and the master cylinder and booster. I also had them flush and refill the brake fluid system, since they were messing with that stuff anyway.

Honestly, I was surprised, as I would have expected a failure of this nature to take place AFTER the warranty had expired. It is a 2009 vehicle, and I bought the extended warranty for 84 months, since I actually bought it in 2010. Didn't have to use the warranty at all up to this particular failure, so I almost made the warranty worth buying. Total bill for the repairs would have come to something like $1200 to $1500, I think.

Anyway, seemed to ride just fine on the way back home from the shop. Truth be known, though, the car ran just fine on the way up to the dealership too, so the sensor failure didn't really affect driving in any way I could tell.

But it does kind of suck that you can't display the error codes on the DIC for the C6 Corvettes like you could for earlier models. Connie had my laptop with my tuning software loaded on it with her, so I couldn't hook it up to take a look at the codes.

I guess had it been out of warranty, I would have replaced that hub myself. Not sure how they determined that the master cylinder was leaking into the booster, though, so I'm not sure I would have caught that problem until it manifested itself in something telling that SOMETHING was wrong.

All in all the experience at the dealership was actually rather pleasant. They have made a lot of changes there since the ownership change and it seems that they are making efforts to be much more customer friendly than they used to be. Not that I had any real complaints when it was Champion Chevrolet, though.
__________________
Rich Z is offline   Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off
Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
C5 Brakes for Chevrolet Corvette C4 - Braking For A Good Cause RSS Feed Tech and How-To Articles 0 10-25-2010 03:00 PM
Service navy2kcoupe Just For Laughs! 0 04-22-2010 08:40 AM
Service? Shadow Just For Laughs! 5 01-22-2009 06:48 AM
Service Department Rant! LEJ ZO6 The Ranting Room 11 12-15-2008 11:38 PM
Worst customer service ever. LS2POWA The Ranting Room 6 08-07-2008 04:46 PM


All times are GMT -4. The time now is 09:16 PM.


Powered by vBulletin® Version 3.7.3
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Page generated in 0.03157806 seconds with 14 queries
All material copyrighted by CorvetteFlorida.com and
the respective owners of the material posted.

Hits since 03/08/2006
Corvette TOP 100 | Top Corvette Sites | Vote for us on the Vette Top 100